# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<number>(?<!\.)\d+(?:\.\d+)?|(?<![\d.])(?:\.\d+)(?!\.))(?<termination>\s*[-+)])"
test_str = ("cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * .2.4)\n"
"cos(3 * 3.4) + cos(3 * 45 ), cos(4 * .24) + cos(3 * 245 )\n\n"
"(3 *(2 + 1 + 1) - 23/5 )\n\n"
"3 * (1571 - sin(12))")
subst = "$1deg$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.