import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<number>(?<!\\.)\\d+(?:\\.\\d+)?|(?<![\\d.])(?:\\.\\d+)(?!\\.))(?<termination>\\s*[-+)])";
final String string = "cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * .2.4)\n"
+ "cos(3 * 3.4) + cos(3 * 45 ), cos(4 * .24) + cos(3 * 245 )\n\n"
+ "(3 *(2 + 1 + 1) - 23/5 )\n\n"
+ "3 * (1571 - sin(12))";
final String subst = "$1deg$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}