const regex = /(?<number>(?<!\.)\d+(?:\.\d+)?|(?<![\d.])(?:\.\d+)(?!\.))(?<termination>\s*[-+)])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<number>(?<!\\.)\\d+(?:\\.\\d+)?|(?<![\\d.])(?:\\.\\d+)(?!\\.))(?<termination>\\s*[-+)])', 'g')
const str = `cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * .2.4)
cos(3 * 3.4) + cos(3 * 45 ), cos(4 * .24) + cos(3 * 245 )
(3 *(2 + 1 + 1) - 23/5 )
3 * (1571 - sin(12))`;
const subst = `$1deg$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);