$re = '/(?<number>(?<!\.)\d+(?:\.\d+)?|(?<![\d.])(?:\.\d+)(?!\.))(?<termination>\s*[-+)])/';
$str = 'cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * .2.4)
cos(3 * 3.4) + cos(3 * 45 ), cos(4 * .24) + cos(3 * 245 )
(3 *(2 + 1 + 1) - 23/5 )
3 * (1571 - sin(12))';
$subst = "$1deg$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;