#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^:\d?\d{3}\s[AP]M\s(?:HST|AKDT|[PCEM]DT)\s[A-Z]{3}\s[A-Z]{3}\s\d?\d\s\d{4}$"
Local $sString = ":530 PM PDT THU APR 16 2015"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")