package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^:\d?\d{3}\s[AP]M\s(?:HST|AKDT|[PCEM]DT)\s[A-Z]{3}\s[A-Z]{3}\s\d?\d\s\d{4}$`)
var str = `:530 PM PDT THU APR 16 2015`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}