const regex = /^:\d?\d{3}\s[AP]M\s(?:HST|AKDT|[PCEM]DT)\s[A-Z]{3}\s[A-Z]{3}\s\d?\d\s\d{4}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^:\\d?\\d{3}\\s[AP]M\\s(?:HST|AKDT|[PCEM]DT)\\s[A-Z]{3}\\s[A-Z]{3}\\s\\d?\\d\\s\\d{4}$', 'g')
const str = `:530 PM PDT THU APR 16 2015`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}