import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^:\\d?\\d{3}\\s[AP]M\\s(?:HST|AKDT|[PCEM]DT)\\s[A-Z]{3}\\s[A-Z]{3}\\s\\d?\\d\\s\\d{4}$";
final String string = ":530 PM PDT THU APR 16 2015";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}