$re = '/^:\d?\d{3}\s[AP]M\s(?:HST|AKDT|[PCEM]DT)\s[A-Z]{3}\s[A-Z]{3}\s\d?\d\s\d{4}$/';
$str = ':530 PM PDT THU APR 16 2015';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);