use strict;
my $str = ':530 PM PDT THU APR 16 2015';
my $regex = qr/^:\d?\d{3}\s[AP]M\s(?:HST|AKDT|[PCEM]DT)\s[A-Z]{3}\s[A-Z]{3}\s\d?\d\s\d{4}$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}