# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/log.html#[^"]*/#/g;t' <<< "<a href=\"log.html#s1-s1-s1\"></a>
<a href=\"log.html#s1-s2-s100\"></a>
<a href=\"log.html#s10-s5-s1\"></a>"