package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`log.html#[^"]*`)
var str = `<a href="log.html#s1-s1-s1"></a>
<a href="log.html#s1-s2-s100"></a>
<a href="log.html#s10-s5-s1"></a>`
var substitution = "#"
fmt.Println(re.ReplaceAllString(str, substitution))
}