using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"log.html#[^""]*";
string substitution = @"#";
string input = @"<a href=""log.html#s1-s1-s1""></a>
<a href=""log.html#s1-s2-s100""></a>
<a href=""log.html#s10-s5-s1""></a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}