use strict;
my $str = '<a href="log.html#s1-s1-s1"></a>
<a href="log.html#s1-s2-s100"></a>
<a href="log.html#s10-s5-s1"></a>';
my $regex = qr/log.html#[^"]*/p;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";