const regex = /log.html#[^"]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('log.html#[^"]*', 'g')
const str = `<a href="log.html#s1-s1-s1"></a>
<a href="log.html#s1-s2-s100"></a>
<a href="log.html#s10-s5-s1"></a>`;
const subst = `#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);