import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "log.html#[^\"]*";
final String string = "<a href=\"log.html#s1-s1-s1\"></a>\n"
+ "<a href=\"log.html#s1-s2-s100\"></a>\n"
+ "<a href=\"log.html#s10-s5-s1\"></a>";
final String subst = "#";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}