package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+([^\s:]+):\s([Y,N])\s`)
var str = []byte(`Sequence: 40 BR Name: ROUTE PARTIAL BR Description: ROUTE PARTIAL BR Action: AFTER ROUTE Enabled: Y rest of text here `)
var substitution = []byte("Seq\t\t\3\t\t\t\t\5\t\t\t\t\7\t\t\9\n\2\t\t\4\t\6\t\t\8\t$10\n")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}