const regex = /^([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+([^\s:]+):\s([Y,N])\s/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\s:]+):\\s(.*?)\\s+BR\\s([^\\s:]+):\\s(.*?)\\s+BR\\s([^\\s:]+):\\s(.*?)\\s+BR\\s([^\\s:]+):\\s(.*?)\\s+([^\\s:]+):\\s([Y,N])\\s', '')
const str = `Sequence: 40 BR Name: ROUTE PARTIAL BR Description: ROUTE PARTIAL BR Action: AFTER ROUTE Enabled: Y rest of text here `;
const subst = `Seq\t\t\3\t\t\t\t\5\t\t\t\t\7\t\t\9\n\2\t\t\4\t\6\t\t\8\t$10\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);