import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\s:]+):\\s(.*?)\\s+BR\\s([^\\s:]+):\\s(.*?)\\s+BR\\s([^\\s:]+):\\s(.*?)\\s+BR\\s([^\\s:]+):\\s(.*?)\\s+([^\\s:]+):\\s([Y,N])\\s";
final String string = "Sequence: 40 BR Name: ROUTE PARTIAL BR Description: ROUTE PARTIAL BR Action: AFTER ROUTE Enabled: Y rest of text here ";
final String subst = "Seq\\t\\t\\3\\t\\t\\t\\t\\5\\t\\t\\t\\t\\7\\t\\t\\9\\n\\2\\t\\t\\4\\t\\6\\t\\t\\8\\t$10\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}