// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+BR\s([^\s:]+):\s(.*?)\s+([^\s:]+):\s([Y,N])\s").unwrap();
let string = "Sequence: 40 BR Name: ROUTE PARTIAL BR Description: ROUTE PARTIAL BR Action: AFTER ROUTE Enabled: Y rest of text here ";
let substitution = "Seq\\t\\t\\3\\t\\t\\t\\t\\5\\t\\t\\t\\t\\7\\t\\t\\9\\n\\2\\t\\t\\4\\t\\6\\t\\t\\8\\t$10\\n";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}