use strict;
my $str = '06 01 02 03 04
+33 6 01 02 03 04
0033 7 01 02 03 04
06 01 02 03 04
+33 6 01 02 03 04
0033 6 01 02 03 04
+33 06 01 02 03 04
0033 06 01 02 03 04
';
my $regex = qr/(?:((?:\+|00)(?:33|33\s0))|0)\s*[1-9](?:[ ]\d{2}){4}
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}