re = /(?:((?:\+|00)(?:33|33\s0))|0)\s*[1-9](?:[ ]\d{2}){4}
/m
str = '06 01 02 03 04
+33 6 01 02 03 04
0033 7 01 02 03 04
06 01 02 03 04
+33 6 01 02 03 04
0033 6 01 02 03 04
+33 06 01 02 03 04
0033 06 01 02 03 04
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end