import re
regex = re.compile((r"(?:((?:\+|00)(?:33|33\s0))|0)\s*[1-9](?:[ ]\d{2}){4}\n"), flags=re.MULTILINE)
test_str = ("06 01 02 03 04\n"
"+33 6 01 02 03 04\n"
"0033 7 01 02 03 04\n"
"06 01 02 03 04\n"
"+33 6 01 02 03 04\n"
"0033 6 01 02 03 04\n"
"+33 06 01 02 03 04\n"
"0033 06 01 02 03 04\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")