# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(>=|<=|==|!=|IN|(?<=[^-+*\\/()=<>,!&| ])\s*-|(?<=[^\\]|^)[+*\\/()=<>,!&|\\])^(-?[0-9]+(.[0-9]+)?)//gm;t' <<< "IF(3>null, '3 > null', '3 !> null')"