use strict;
my $str = 'IF(3>null, \'3 > null\', \'3 !> null\')';
my $regex = qr/(>=|<=|==|!=|IN|(?<=[^-+*\/()=<>,!&| ])\s*-|(?<=[^\\]|^)[+*\/()=<>,!&|\\])^(-?[0-9]+(.[0-9]+)?)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";