$re = '/(>=|<=|==|!=|IN|(?<=[^-+*\/()=<>,!&| ])\s*-|(?<=[^\\\\]|^)[+*\/()=<>,!&|\\\\])^(-?[0-9]+(.[0-9]+)?)/m';
$str = 'IF(3>null, \'3 > null\', \'3 !> null\')';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;