import re
regex = re.compile(r"(>=|<=|==|!=|IN|(?<=[^-+*\/()=<>,!&| ])\s*-|(?<=[^\\]|^)[+*\/()=<>,!&|\\])^(-?[0-9]+(.[0-9]+)?)", flags=re.MULTILINE)
test_str = "IF(3>null, '3 > null', '3 !> null')"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)