re = /(>=|<=|==|!=|IN|(?<=[^-+*\/()=<>,!&| ])\s*-|(?<=[^\\]|^)[+*\/()=<>,!&|\\])^(-?[0-9]+(.[0-9]+)?)/m
str = 'IF(3>null, \'3 > null\', \'3 !> null\')'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result