using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(>=|<=|==|!=|IN|(?<=[^-+*\/()=<>,!&| ])\s*-|(?<=[^\\]|^)[+*\/()=<>,!&|\\])^(-?[0-9]+(.[0-9]+)?)";
string substitution = @"";
string input = @"IF(3>null, '3 > null', '3 !> null')";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}