#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:([a-z]+)(?::\/\/))?((?:www.)?(?:\w+-?)+\w+(?:\.\w{2,3}){1,2})\/((?:(?:\w+-?\w+\/?)+)\.\w+)(?:(?:\?)([^#]*)(?:(?:#)(\w+))?)?"
Local $sString = "http://domain.com/path/index.html?key=value#hash"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")