import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:([a-z]+)(?::\\/\\/))?((?:www.)?(?:\\w+-?)+\\w+(?:\\.\\w{2,3}){1,2})\\/((?:(?:\\w+-?\\w+\\/?)+)\\.\\w+)(?:(?:\\?)([^#]*)(?:(?:#)(\\w+))?)?";
final String string = "http://domain.com/path/index.html?key=value#hash";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}