// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:([a-z]+)(?::\/\/))?((?:www.)?(?:\w+-?)+\w+(?:\.\w{2,3}){1,2})\/((?:(?:\w+-?\w+\/?)+)\.\w+)(?:(?:\?)([^#]*)(?:(?:#)(\w+))?)?").unwrap();
let string = "http://domain.com/path/index.html?key=value#hash";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}