re = /(?:([a-z]+)(?::\/\/))?((?:www.)?(?:\w+-?)+\w+(?:\.\w{2,3}){1,2})\/((?:(?:\w+-?\w+\/?)+)\.\w+)(?:(?:\?)([^#]*)(?:(?:#)(\w+))?)?/i
str = 'http://domain.com/path/index.html?key=value#hash'
# Print the match result
str.match(re) do |match|
puts match.to_s
end