import re
regex = re.compile(r"(?:([a-z]+)(?::\/\/))?((?:www.)?(?:\w+-?)+\w+(?:\.\w{2,3}){1,2})\/((?:(?:\w+-?\w+\/?)+)\.\w+)(?:(?:\?)([^#]*)(?:(?:#)(\w+))?)?", flags=re.IGNORECASE)
test_str = "http://domain.com/path/index.html?key=value#hash"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")