const regex = /(?:([a-z]+)(?::\/\/))?((?:www.)?(?:\w+-?)+\w+(?:\.\w{2,3}){1,2})\/((?:(?:\w+-?\w+\/?)+)\.\w+)(?:(?:\?)([^#]*)(?:(?:#)(\w+))?)?/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([a-z]+)(?::\\\/\\\/))?((?:www.)?(?:\\w+-?)+\\w+(?:\\.\\w{2,3}){1,2})\\\/((?:(?:\\w+-?\\w+\\\/?)+)\\.\\w+)(?:(?:\\?)([^#]*)(?:(?:#)(\\w+))?)?', 'i')
const str = `http://domain.com/path/index.html?key=value#hash`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}