#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http://(?:sv\d+sv|hv\d+hv)-prod-domain\.com/health"
Local $sString = "http://sv01sv-prod-domain.com/health" & @CRLF & _
"http://sv02sv-prod-domain.com/health" & @CRLF & _
"http://sv03sv-prod-domain.com/health" & @CRLF & _
"" & @CRLF & _
"I now need to add servers that are named:" & @CRLF & _
"" & @CRLF & _
"http://hv??hv-prod-domain.com/health" & @CRLF & _
"" & @CRLF & _
"http://hv01hv-prod-domain.com/health" & @CRLF & _
"http://hv02hv-prod-domain.com/health" & @CRLF & _
"http://hv03hv-prod-domain.com/health"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")