package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http://(?:sv\d+sv|hv\d+hv)-prod-domain\.com/health`)
var str = `http://sv01sv-prod-domain.com/health
http://sv02sv-prod-domain.com/health
http://sv03sv-prod-domain.com/health
I now need to add servers that are named:
http://hv??hv-prod-domain.com/health
http://hv01hv-prod-domain.com/health
http://hv02hv-prod-domain.com/health
http://hv03hv-prod-domain.com/health`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}