using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http://(?:sv\d+sv|hv\d+hv)-prod-domain\.com/health";
string input = @"http://sv01sv-prod-domain.com/health
http://sv02sv-prod-domain.com/health
http://sv03sv-prod-domain.com/health
I now need to add servers that are named:
http://hv??hv-prod-domain.com/health
http://hv01hv-prod-domain.com/health
http://hv02hv-prod-domain.com/health
http://hv03hv-prod-domain.com/health";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}