const regex = new RegExp('http://(?:sv\\d+sv|hv\\d+hv)-prod-domain\\.com/health', 'gm')
const str = `http://sv01sv-prod-domain.com/health
http://sv02sv-prod-domain.com/health
http://sv03sv-prod-domain.com/health
I now need to add servers that are named:
http://hv??hv-prod-domain.com/health
http://hv01hv-prod-domain.com/health
http://hv02hv-prod-domain.com/health
http://hv03hv-prod-domain.com/health`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}