re = /http:\/\/(?:sv\d+sv|hv\d+hv)-prod-domain\.com\/health/m
str = 'http://sv01sv-prod-domain.com/health
http://sv02sv-prod-domain.com/health
http://sv03sv-prod-domain.com/health
I now need to add servers that are named:
http://hv??hv-prod-domain.com/health
http://hv01hv-prod-domain.com/health
http://hv02hv-prod-domain.com/health
http://hv03hv-prod-domain.com/health'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end