import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http://(?:sv\\d+sv|hv\\d+hv)-prod-domain\\.com/health";
final String string = "http://sv01sv-prod-domain.com/health\n"
+ "http://sv02sv-prod-domain.com/health\n"
+ "http://sv03sv-prod-domain.com/health\n\n"
+ "I now need to add servers that are named:\n\n"
+ "http://hv??hv-prod-domain.com/health\n\n"
+ "http://hv01hv-prod-domain.com/health\n"
+ "http://hv02hv-prod-domain.com/health\n"
+ "http://hv03hv-prod-domain.com/health";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}