using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^()]+)\(([^()]*)\)";
string substitution = @"$1 $2";
string input = @"ABC1.1(1) 拆分为ABC1.1和1 两部分
%DEF2.1(3) 拆分为%DEF2.1和3 两部分
@ I/O GHI3.3(5) 拆分为@ I/O GHI3.3 和5 两部分
ABC1.1(1)
%DEF2.1(3)
@ I/O GHI3.3(5) ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}