use strict;
my $str = 'ABC1.1(1) 拆分为ABC1.1和1 两部分
%DEF2.1(3) 拆分为%DEF2.1和3 两部分
@ I/O GHI3.3(5) 拆分为@ I/O GHI3.3 和5 两部分
ABC1.1(1)
%DEF2.1(3)
@ I/O GHI3.3(5) ';
my $regex = qr/([^()]+)\(([^()]*)\)/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";