import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^()]+)\\(([^()]*)\\)";
final String string = "ABC1.1(1) 拆分为ABC1.1和1 两部分\n"
+ "%DEF2.1(3) 拆分为%DEF2.1和3 两部分\n"
+ "@ I/O GHI3.3(5) 拆分为@ I/O GHI3.3 和5 两部分\n\n"
+ "ABC1.1(1) \n"
+ "%DEF2.1(3) \n"
+ "@ I/O GHI3.3(5) ";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}