// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^()]+)\(([^()]*)\)").unwrap();
let string = "ABC1.1(1) 拆分为ABC1.1和1 两部分
%DEF2.1(3) 拆分为%DEF2.1和3 两部分
@ I/O GHI3.3(5) 拆分为@ I/O GHI3.3 和5 两部分
ABC1.1(1)
%DEF2.1(3)
@ I/O GHI3.3(5) ";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}