#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<!<saw:columnHeading>).<saw:displayFormat>(.*?)<\/saw:displayFormat>.(?!<\/saw:columnHeading>)"
Local $sString = "<saw:column columnID="c83" xsi:type="saw:regularColumn"> " & @CRLF & _
"<saw:displayFormat>" & @CRLF & _
"<saw:formatSpec visibility="hidden" suppress="default" interaction="default" wrapText="true"/>" & @CRLF & _
"</saw:displayFormat> " & @CRLF & _
"<saw:columnHeading> " & @CRLF & _
"<saw:displayFormat>" & @CRLF & _
"<saw:formatSpec interaction="default"/>" & @CRLF & _
"</saw:displayFormat>" & @CRLF & _
"</saw:columnHeading>" & @CRLF & _
" <saw:columnFormula>" & @CRLF & _
"<sawx:expr xsi:type="sawx:sqlExpression">max("Supply Fact"."Count")</sawx:expr></saw:columnFormula>" & @CRLF & _
"</saw:column>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")