re = /(?<!<saw:columnHeading>).<saw:displayFormat>(.*?)<\/saw:displayFormat>.(?!<\/saw:columnHeading>)/
str = '<saw:column columnID="c83" xsi:type="saw:regularColumn">
<saw:displayFormat>
<saw:formatSpec visibility="hidden" suppress="default" interaction="default" wrapText="true"/>
</saw:displayFormat>
<saw:columnHeading>
<saw:displayFormat>
<saw:formatSpec interaction="default"/>
</saw:displayFormat>
</saw:columnHeading>
<saw:columnFormula>
<sawx:expr xsi:type="sawx:sqlExpression">max("Supply Fact"."Count")</sawx:expr></saw:columnFormula>
</saw:column>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end