using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!<saw:columnHeading>).<saw:displayFormat>(.*?)<\/saw:displayFormat>.(?!<\/saw:columnHeading>)";
string input = @"<saw:column columnID=""c83"" xsi:type=""saw:regularColumn"">
<saw:displayFormat>
<saw:formatSpec visibility=""hidden"" suppress=""default"" interaction=""default"" wrapText=""true""/>
</saw:displayFormat>
<saw:columnHeading>
<saw:displayFormat>
<saw:formatSpec interaction=""default""/>
</saw:displayFormat>
</saw:columnHeading>
<saw:columnFormula>
<sawx:expr xsi:type=""sawx:sqlExpression"">max(""Supply Fact"".""Count"")</sawx:expr></saw:columnFormula>
</saw:column>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}