import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!<saw:columnHeading>).<saw:displayFormat>(.*?)<\\/saw:displayFormat>.(?!<\\/saw:columnHeading>)";
final String string = "<saw:column columnID=\"c83\" xsi:type=\"saw:regularColumn\"> \n"
+ "<saw:displayFormat>\n"
+ "<saw:formatSpec visibility=\"hidden\" suppress=\"default\" interaction=\"default\" wrapText=\"true\"/>\n"
+ "</saw:displayFormat> \n"
+ "<saw:columnHeading> \n"
+ "<saw:displayFormat>\n"
+ "<saw:formatSpec interaction=\"default\"/>\n"
+ "</saw:displayFormat>\n"
+ "</saw:columnHeading>\n"
+ " <saw:columnFormula>\n"
+ "<sawx:expr xsi:type=\"sawx:sqlExpression\">max(\"Supply Fact\".\"Count\")</sawx:expr></saw:columnFormula>\n"
+ "</saw:column>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}