const regex = /(?<!<saw:columnHeading>).<saw:displayFormat>(.*?)<\/saw:displayFormat>.(?!<\/saw:columnHeading>)/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!<saw:columnHeading>).<saw:displayFormat>(.*?)<\\\/saw:displayFormat>.(?!<\\\/saw:columnHeading>)', 'sg')
const str = `<saw:column columnID="c83" xsi:type="saw:regularColumn">
<saw:displayFormat>
<saw:formatSpec visibility="hidden" suppress="default" interaction="default" wrapText="true"/>
</saw:displayFormat>
<saw:columnHeading>
<saw:displayFormat>
<saw:formatSpec interaction="default"/>
</saw:displayFormat>
</saw:columnHeading>
<saw:columnFormula>
<sawx:expr xsi:type="sawx:sqlExpression">max("Supply Fact"."Count")</sawx:expr></saw:columnFormula>
</saw:column>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}